Miltek rattle

4.0 V8 40v biturbo TFSI - 553 bhp
4.0 V8 40v biturbo TFSI - 597 bhp (Performance)
Post Reply
MountainMutant
2nd Gear
Posts: 221
Joined: Sat May 13, 2006 7:29 pm

Miltek rattle

Post by MountainMutant » Tue Sep 10, 2019 11:34 am

I have a miltek cat back non resonated exhaust which has an annoying flutter/rattle sound when off the throttle at around 1500 revs.

I'm guessing it's something to to with the valves which are disconnected using the Miltek valve delete.

Has anyone else had this problem and found a solution?

MM
2017 RS6 PE Nogaro 💙

hdpete
2nd Gear
Posts: 168
Joined: Sat Mar 12, 2016 6:57 pm

Re: Miltek rattle

Post by hdpete » Tue Sep 10, 2019 12:28 pm

I’ve been holding off posting exactly the same!

It sounds like a loose panel in the boot, but is definitely valve related.

I think I’ll get it checked out.

hdpete
2nd Gear
Posts: 168
Joined: Sat Mar 12, 2016 6:57 pm

Re: Miltek rattle

Post by hdpete » Tue Sep 10, 2019 12:29 pm

I Reconnected my valves and it’s still noticeable

User avatar
MikeFish
Cruising
Posts: 15163
Joined: Tue Aug 31, 2010 9:23 pm
Location: The Middle of Somewhere

Re: Miltek rattle

Post by MikeFish » Tue Sep 10, 2019 9:55 pm

A squirt of wd40 in the end of the exhaust normally gets rid of it for a while. Try that, if it works you can try a more permanent solution (ptfe spray etc maybe?)

dasquade
2nd Gear
Posts: 227
Joined: Wed Apr 06, 2016 11:36 pm

Re: Miltek rattle

Post by dasquade » Wed Sep 11, 2019 12:50 am

1. it can be the extra spring under the valve that is giving you issues (wd40 helps some time, removing the spring fixes it forever and lets you sleep good at night).
-> see other topic on here where i explained it better including pictures....
2. the milltek has an tinny H pipe that makes internal sounds way more audiate. I always guessed the dual flip wastegate port flapper kinda was the influencer and what you are hearing. Since i replaced the poor quality H with an X pipe the milltek sound more refined (but way softer).

User avatar
Iain
4th Gear
Posts: 672
Joined: Tue Jan 14, 2003 5:13 pm
Location: Cardiff

Re: Miltek rattle

Post by Iain » Thu Sep 12, 2019 10:56 am

If it's like a ticking sound when off the throttle around 1500rpm, then had it on both my 6's - assumed it was part and parcel of the Milltek.
2017 RS6 PE -Nardo, Air, HUD, Pan.....Millie Non Res
2015 RS6 - with Added Milltek
2015 RRS - utter sh1te
2010 X5 4.0D M Sport Every conceivable extra
2010 X5 4.0D M Sport
2009 R8 V10 Manual
2004 Lambo Gallarado Manual
3 x 997 C4S / C2s
2003 Fezza 360 Spider - Airfix kit build quality
2007 M3 - car number 2 in the UK
2006 RS4 Avant
2000 RS4 MTM Stage 3 - R55 BYE
2001 RS4 - R500 FOR
1990 Dimma Cosworth H20 COS
2006 CL500
2003 996 DMS Turbo
multiple 205's Turbo Technics, Dimmas etc

2Brains
Neutral
Posts: 39
Joined: Sat Oct 06, 2018 11:42 am

Re: Miltek rattle

Post by 2Brains » Thu Sep 12, 2019 1:30 pm

Iain wrote:
Thu Sep 12, 2019 10:56 am
If it's like a ticking sound when off the throttle around 1500rpm, then had it on both my 6's - assumed it was part and parcel of the Milltek.
Agreed. Mine has been like this since I got the Miltek and always felt the noise didn’t warrant the work required to try remove the common rattles off throttle. WD40 never worked for me either.
Edinburgh Based Nardo Grey C7 RS6

User avatar
MikeFish
Cruising
Posts: 15163
Joined: Tue Aug 31, 2010 9:23 pm
Location: The Middle of Somewhere

Re: Miltek rattle

Post by MikeFish » Thu Sep 12, 2019 6:57 pm

Iain wrote:
Thu Sep 12, 2019 10:56 am
If it's like a ticking sound when off the throttle around 1500rpm, then had it on both my 6's - assumed it was part and parcel of the Milltek.
Did you try spraying the valves with wd40?

User avatar
uplandsway
3rd Gear
Posts: 370
Joined: Tue Sep 04, 2018 3:32 pm

Re: Miltek rattle

Post by uplandsway » Fri Sep 13, 2019 6:57 am

MikeFish wrote:
Iain wrote:
Thu Sep 12, 2019 10:56 am
If it's like a ticking sound when off the throttle around 1500rpm, then had it on both my 6's - assumed it was part and parcel of the Milltek.
Did you try spraying the valves with wd40?
Like Mr C7 RS6 Mike says do the WD40 trick before you scrap it for the new APR System Image


Sent from my iPhone using Tapatalk
Cheers,
Stevie F
2016 C7.5 RS6 Performance

User avatar
Iain
4th Gear
Posts: 672
Joined: Tue Jan 14, 2003 5:13 pm
Location: Cardiff

Re: Miltek rattle

Post by Iain » Fri Sep 13, 2019 7:00 am

MikeFish wrote:
Thu Sep 12, 2019 6:57 pm
Iain wrote:
Thu Sep 12, 2019 10:56 am
If it's like a ticking sound when off the throttle around 1500rpm, then had it on both my 6's - assumed it was part and parcel of the Milltek.
Did you try spraying the valves with wd40?
Spray the valves regularly - did do with both of them, though not to get rid of ticking noise, more OCD of not wanting the valves to stick. Not sure it's a fault per se with the exhausts as it seems to occur on most of them / a large number of them - normal behaviour with exhaust? Has anyone spoken to Milltek to ask them directly?
2017 RS6 PE -Nardo, Air, HUD, Pan.....Millie Non Res
2015 RS6 - with Added Milltek
2015 RRS - utter sh1te
2010 X5 4.0D M Sport Every conceivable extra
2010 X5 4.0D M Sport
2009 R8 V10 Manual
2004 Lambo Gallarado Manual
3 x 997 C4S / C2s
2003 Fezza 360 Spider - Airfix kit build quality
2007 M3 - car number 2 in the UK
2006 RS4 Avant
2000 RS4 MTM Stage 3 - R55 BYE
2001 RS4 - R500 FOR
1990 Dimma Cosworth H20 COS
2006 CL500
2003 996 DMS Turbo
multiple 205's Turbo Technics, Dimmas etc

MountainMutant
2nd Gear
Posts: 221
Joined: Sat May 13, 2006 7:29 pm

Re: Miltek rattle

Post by MountainMutant » Fri Sep 13, 2019 7:39 am

I have sprayed the valves and it doesn’t seem to do much.

The valves are disconnected so shouldn’t be moving
2017 RS6 PE Nogaro 💙

User avatar
uplandsway
3rd Gear
Posts: 370
Joined: Tue Sep 04, 2018 3:32 pm

Re: Miltek rattle

Post by uplandsway » Fri Sep 13, 2019 7:44 am

MountainMutant wrote:I have sprayed the valves and it doesn’t seem to do much.

The valves are disconnected so shouldn’t be moving
Have you tried the opposite way

Plug valve units back in

Soak the internals in WD40 overnight

Use in comfort and sport to see if it frees up issues and continue to soak units

Or just eBay the milly and buy the APR, huge step forward in terms of quality and sound


Sent from my iPhone using Tapatalk
Cheers,
Stevie F
2016 C7.5 RS6 Performance

Post Reply

Return to “RS6 (C7 Typ 4G) 2013-2018”

Who is online

Users browsing this forum: don0301, MAVAV, Scotty C and 6 guests