Lumpy idle and Oil Smell

5.2 V10 40v Naturally Aspirated - 429bhp
Post Reply
User avatar
travs
2nd Gear
Posts: 136
Joined: Wed Jul 18, 2007 8:38 pm
Location: Surbiton, Surrey

Lumpy idle and Oil Smell

Post by travs » Sun Mar 18, 2018 12:07 pm

Hi all,



Hoping to tap into a few minds here.



Had an engine service with the gearbox oil serviced (dialysis machine employed) and, long story short, had a couple of O2 sensors changed as ATF got spilled on them ruining them causing massive economy-loss and running like crap (running rich as a limp mode) - fine when cold, got steadily worse. It had been back and forth to the garage (Brooklands in Swanley, as he wanted to resolve it) and it seemed to be settling except for the smell. No fluid dripping although I know the undertray may hide this somewhat. Aside from the consistent smell, the idle was sometimes smooth as silk, and sometimes ever so marginally odd. Really annoyingly inconsistent.



Until yesterday. First time driving it for a week, the idle was much worse after about a minute or two of driving. I'd checked the fluids and topped up the oil a little.



The idle was shaking the car about, but as soon as any movement, the engine seemed to run fine.

Did a run from M25 J9 to A2 Dartford and, by the time I pulled off in Dartford, the smell was so bad it was in the cab even with recirc on, and there was a little smoke emanating from the left side of the bonnet. Very light in colour and volume - not sure if it was white or very light blue. Back on the move very gently as had no other option and, again, car seemed to run fine. No hesitancy or juddering.

Had to bring the car back home last night (as have a 1-month old now and little other option) and car seemed to run absolutely fine again except for the idle - either in N or in D with foot on the brake.



Rather than moan about the garage, because I do trust the guy and took full responsibility for the O2 sensors, I'm wondering whether this is just coincidental and I'm starting to get the coking. Car is 06, 91k miles and I'm pretty sure its never been done. No rattling from engine although I'm yet to go down and check fluid levels this morning.



Is this idle-only symptom indicative of anything over anything else?



As an aside, if it is, I was wondering about having the manifold flaps looked at - are these replacement parts or a new manifold?
Night Blue Metallic S6 5.2 V10 - Private plate, LED interior kit.
Previously:
Hibiscus Red Metallic S4 (B5 99.5) w/AmD Stage 1 Remap, RS4 Exhaust w/ Gutted Precats & R32 Tailpipes, Afterun Sensor, H&R Coilovers

Post Reply

Return to “S6 (C6 Typ 4F) 2006-2011”

Who is online

Users browsing this forum: No registered users and 3 guests