Limp Mode / rev limiter - without error code

4.2 V8 32v Naturally Aspirated - 414 bhp
Post Reply
highrise
1st Gear
Posts: 67
Joined: Mon Sep 13, 2021 11:00 am

Limp Mode / rev limiter - without error code

Post by highrise » Mon Feb 12, 2024 2:37 pm

Hi,

Any common reasons for the car going into limp mode (6.5k rev limiter) without showing an error code?

I had a decoke and remap, after this I had a couple of flap error codes (P2020 & P2015) coded out.

The rev limited seems to be on from start-up or at least as soon as you drive.

Am I not seeing the error due to the remap and coding out other errors? Or are there issues that will put the car into limp mode without throwing a code?

Thanks

JRC1
Neutral
Posts: 48
Joined: Fri Mar 08, 2019 8:11 pm

Re: Limp Mode / rev limiter - without error code

Post by JRC1 » Mon Feb 12, 2024 6:58 pm

Is this not just the soft limiter that is mapped in until the car is warm? Or are you saying it still won't go past 6.5k when the car is fully up to temp?

highrise
1st Gear
Posts: 67
Joined: Mon Sep 13, 2021 11:00 am

Re: Limp Mode / rev limiter - without error code

Post by highrise » Tue Feb 13, 2024 11:04 am

Is there a soft limiter? I thought you just had a polite message in the dash.

No this is when the car is fully warm.

I think it briefly goes away of you turn the car off.

JRC1
Neutral
Posts: 48
Joined: Fri Mar 08, 2019 8:11 pm

Re: Limp Mode / rev limiter - without error code

Post by JRC1 » Tue Feb 13, 2024 6:31 pm

Yes, there is a soft limiter. It won't rev past 7k until the oil temp reaches 70 degrees from memory.

But if it's still happening for you when fully up to temp it could be a sensor. Worth getting the people that re-mapped to check?

highrise
1st Gear
Posts: 67
Joined: Mon Sep 13, 2021 11:00 am

Re: Limp Mode / rev limiter - without error code

Post by highrise » Wed Feb 14, 2024 11:00 pm

Thanks.

The 7k warning goes off, so guess the temp sensor is working.

I agree, probably need the tuner to check it.

KNN
Neutral
Posts: 5
Joined: Thu Feb 09, 2023 6:53 pm

Re: Limp Mode / rev limiter - without error code

Post by KNN » Fri Apr 05, 2024 8:05 pm

Hi Highrise,

My friend had the same issue for a year, spent a lot of money changing so many things, and finally it was the injectors. He replaced all injectors.

If you do not want to replace them, then get a garage to perform testing on all the injectors to see if it is working and balanced fuel delivery.

highrise
1st Gear
Posts: 67
Joined: Mon Sep 13, 2021 11:00 am

Re: Limp Mode / rev limiter - without error code

Post by highrise » Mon Apr 08, 2024 10:04 pm

Hi,

Thanks for the reply.

My independent sorted the issue but removing and re adding the map. Not completely sure of the issue but appeared to relate to coding out the flap error I was getting after being removed.

Sorted in time to drive 1.5k to the Alps back, amazing drive. The RS4 was suited to the fast french toll road runs and then twisty mountain roads. Also a night in Paris, great to have an old school normal sized car for that bit.

MPG was terrifying obviously!

Post Reply

Return to “RS4 (B7 Typ 8E) 2006–2008”

Who is online

Users browsing this forum: beckford21 and 241 guests