O2 Sensors - Anyone having trouble with them?

4.2 V8 32v Naturally Aspirated - 414 bhp
Post Reply
User avatar
oxblood8
Neutral
Posts: 36
Joined: Tue Jan 28, 2014 3:57 am

O2 Sensors - Anyone having trouble with them?

Post by oxblood8 » Sat Mar 13, 2021 10:35 pm

Hi All

So I have got the CEL light on again this time with fault P0036 - Heater Control Circuit Bank 1 Sensor 2.

I had this sensor replaced in December 2019, that was throwing the P0041 fault. My mechanic is following up with supplier.

I've heard that there are a lot of dodgy parts around these days. Is anyone else having issues with O2 sensors?

AA_954
1st Gear
Posts: 87
Joined: Thu Mar 29, 2018 9:23 am

Re: O2 Sensors - Anyone having trouble with them?

Post by AA_954 » Sun Mar 14, 2021 12:33 am

oxblood8 wrote:Hi All

So I have got the CEL light on again this time with fault P0036 - Heater Control Circuit Bank 1 Sensor 2.

I had this sensor replaced in December 2019, that was throwing the P0041 fault. My mechanic is following up with supplier.

I've heard that there are a lot of dodgy parts around these days. Is anyone else having issues with O2 sensors?
Like some of the lads here in the US I went with the OE Bosch ones that I bought on Rockauto.com, I changed all 4 at ~72k miles during the CC (2 years / 6k miles ago ) and so far no issues.

I did get the P0036 code about 3-4 months ago on my Golf R with 18k miles and the mechanic and I think it probably went early as I’m tuned for and used E85 on that car, other than that they should probably last longer Image.

Having to change the same sensor after 2 years doesn’t seem normal at all, did you go with OEM/Bosch back then? Are you by chance catless?


Sent from my iPhone using Tapatalk Pro

User avatar
oxblood8
Neutral
Posts: 36
Joined: Tue Jan 28, 2014 3:57 am

Re: O2 Sensors - Anyone having trouble with them?

Post by oxblood8 » Tue Mar 16, 2021 12:38 am

AA_954 wrote:
Sun Mar 14, 2021 12:33 am
Having to change the same sensor after 2 years doesn’t seem normal at all, did you go with OEM/Bosch back then? Are you by chance catless?
My mechanic said that it came in a Bosch box and seemed legit. Nah not catless, only thing done is I had the center resonator removed last december.

Post Reply

Return to “RS4 (B7 Typ 8E) 2006–2008”

Who is online

Users browsing this forum: No registered users and 35 guests