Instrument Cluster

4.2 V8 40v biturbo - 450 bhp
4.2 V8 40v biturbo - 480 bhp (plus)
steve2003rs6
3rd Gear
Posts: 440
Joined: Mon Aug 19, 2019 7:43 pm
Location: Cleethorpes UK

Re: Instrument Cluster

Post by steve2003rs6 » Mon Jun 29, 2020 8:24 am

Don’t know if this is related.
On startup. The temp display on the climate control and new dis display reverts to degrees Fahrenheit.
Reset it using the recirc button and the + button.
Not every startup just now and again.

User avatar
Shoppinit
Cruising
Posts: 17164
Joined: Wed Dec 31, 2008 6:24 pm

Re: Instrument Cluster

Post by Shoppinit » Mon Jun 29, 2020 8:26 am

That's weird. Maybe it's a coding issue, but why would it happen on both clusters?

/nah, just checked. Coding is correct. 01484
Daytona RS6 C5 Avant. Viper'd, Billies, Waggers, MTM box brain, C6 stoppers, xcarlink, R8 coolant cap (woohoo)
///M3 E46 -- XC90 (V8, natch)
"The major difference between a thing that might go wrong and a thing that cannot possibly go wrong is that when a thing that cannot possibly go wrong goes wrong it usually turns out to be impossible to get at and repair."

steve2003rs6
3rd Gear
Posts: 440
Joined: Mon Aug 19, 2019 7:43 pm
Location: Cleethorpes UK

Re: Instrument Cluster

Post by steve2003rs6 » Mon Jun 29, 2020 9:06 am

When I wake up and get sorted.
Will try fuses.
Then leaning towards wire broke in cable ?
Will see if I can find someone local to try to power it up if I remove it.
Ps just wish audi gave you a bit more cable at the back to assist in removal/installation.

User avatar
Shoppinit
Cruising
Posts: 17164
Joined: Wed Dec 31, 2008 6:24 pm

Re: Instrument Cluster

Post by Shoppinit » Mon Jun 29, 2020 9:15 am

Check the following:

1. Thin brown wire from the headlight switch. Make sure it goes to earth properly. Test continuity between where it connects at the switch and the body earth.
2. Thin green/purple wire from headlight switch to cluster, the green 32 pin connector. It's a direct connection. Check continuity between the cluster and the switch, preferably with both unplugged.
Daytona RS6 C5 Avant. Viper'd, Billies, Waggers, MTM box brain, C6 stoppers, xcarlink, R8 coolant cap (woohoo)
///M3 E46 -- XC90 (V8, natch)
"The major difference between a thing that might go wrong and a thing that cannot possibly go wrong is that when a thing that cannot possibly go wrong goes wrong it usually turns out to be impossible to get at and repair."

steve2003rs6
3rd Gear
Posts: 440
Joined: Mon Aug 19, 2019 7:43 pm
Location: Cleethorpes UK

Re: Instrument Cluster

Post by steve2003rs6 » Mon Jun 29, 2020 9:41 am

Cheers Shop.

steve2003rs6
3rd Gear
Posts: 440
Joined: Mon Aug 19, 2019 7:43 pm
Location: Cleethorpes UK

Re: Instrument Cluster

Post by steve2003rs6 » Mon Jun 29, 2020 10:15 am

Spoke to auto electrician.
He thinks that it is a can high or a can low issue and something is turned off.

User avatar
Shoppinit
Cruising
Posts: 17164
Joined: Wed Dec 31, 2008 6:24 pm

Re: Instrument Cluster

Post by Shoppinit » Mon Jun 29, 2020 10:45 am

Mmm. I'm not convinced. The control for the illumination looks like a pure analogue circuit, but I could be wrong. There's not a lot of info on the inner workings of the cluster I can access.

The coding of your unit is correct and the adaptation channels don't show anything to do with the illumination so I'd be very surprised if it was a CAN thing.

Why don't you ask the people that did the LCD if they know what it could be? Maybe run this CAN thing by them.
Daytona RS6 C5 Avant. Viper'd, Billies, Waggers, MTM box brain, C6 stoppers, xcarlink, R8 coolant cap (woohoo)
///M3 E46 -- XC90 (V8, natch)
"The major difference between a thing that might go wrong and a thing that cannot possibly go wrong is that when a thing that cannot possibly go wrong goes wrong it usually turns out to be impossible to get at and repair."

steve2003rs6
3rd Gear
Posts: 440
Joined: Mon Aug 19, 2019 7:43 pm
Location: Cleethorpes UK

Re: Instrument Cluster

Post by steve2003rs6 » Mon Jun 29, 2020 11:24 am

Cartronix said the cluster all checked out fine. Said may be control module or convenience module.

steve2003rs6
3rd Gear
Posts: 440
Joined: Mon Aug 19, 2019 7:43 pm
Location: Cleethorpes UK

Re: Instrument Cluster

Post by steve2003rs6 » Mon Jun 29, 2020 12:28 pm

Been to see a audi tech who now works for himself.
Using my VCDS / laptop. Couldn’t keep up with what he was doing.
Unable to communicate with the control module that relates to lighting.
Going back on Thursday and he reckons he can sort it.
Fingers crossed.
Ps he told me that he used to work on my car when he was at AMD.
Last edited by steve2003rs6 on Mon Jun 29, 2020 6:23 pm, edited 1 time in total.

steve2003rs6
3rd Gear
Posts: 440
Joined: Mon Aug 19, 2019 7:43 pm
Location: Cleethorpes UK

Re: Instrument Cluster

Post by steve2003rs6 » Mon Jun 29, 2020 5:06 pm

Shop. Wiring checked out ok. Noticed that no backlight illumination on the switch as well.
Also the thumbwheel light adjuster works on the dis display. Can fade or increase the intensity

ChrisA
2nd Gear
Posts: 158
Joined: Thu May 07, 2020 11:28 am
Location: Langstone, nr. Portsmouth

Re: Instrument Cluster

Post by ChrisA » Mon Jun 29, 2020 9:15 pm

Steve, sorry for the highjack but I’ve just seen this on FB. Looks very smart.😎 I asked the owner for more info but he didn’t seem to interested in looking for the info. He did say it was done in Germany.

92915867-A3DA-47AC-BF47-B10105B5EFB2.png

steve2003rs6
3rd Gear
Posts: 440
Joined: Mon Aug 19, 2019 7:43 pm
Location: Cleethorpes UK

Re: Instrument Cluster

Post by steve2003rs6 » Mon Jun 29, 2020 9:29 pm

Hi Chris. I did see a fellow member on here had a “coloured” uprated screen fitted. Don’t know what type. Yes looks good in the photo.
Pleased you don’t have to do this very often. It’s a pain. But pleased I no longer have to look at faded/missing pixels.
Hopefully get backlighting sorted this week.
Love VCDS but today showed me how much a novice I am with it.

User avatar
Shoppinit
Cruising
Posts: 17164
Joined: Wed Dec 31, 2008 6:24 pm

Re: Instrument Cluster

Post by Shoppinit » Mon Jun 29, 2020 10:05 pm

If you do get this problem sorted by someone, try to find out exactly what the issue was. I’m curious to know what the fault is.
Daytona RS6 C5 Avant. Viper'd, Billies, Waggers, MTM box brain, C6 stoppers, xcarlink, R8 coolant cap (woohoo)
///M3 E46 -- XC90 (V8, natch)
"The major difference between a thing that might go wrong and a thing that cannot possibly go wrong is that when a thing that cannot possibly go wrong goes wrong it usually turns out to be impossible to get at and repair."

steve2003rs6
3rd Gear
Posts: 440
Joined: Mon Aug 19, 2019 7:43 pm
Location: Cleethorpes UK

Re: Instrument Cluster

Post by steve2003rs6 » Mon Jun 29, 2020 10:16 pm

Hi Shop will do.
I just turned up without any pre arrangement.
From what I saw. Using VCDS he checked numerous settings/codes and all was ok. Then tried to access the module for lighting and wouldn’t allow any access. He said something about module not being recognised.
Wiring checked out ok.
Please forgive my lack of technicality. He was so quick with VCDS I couldn’t keep up.
Arranged to visit him on Thursday.
Although he was stacked out with customers spent 1/2 hour on my car there and then to see what he could do.
It also transpired that he has just purchased a c5 RS6.

User avatar
IchBautAuto
3rd Gear
Posts: 271
Joined: Thu Feb 20, 2014 11:23 pm

Re: Instrument Cluster

Post by IchBautAuto » Tue Jun 30, 2020 12:45 am

ChrisA wrote:
Mon Jun 29, 2020 9:15 pm
Steve, sorry for the highjack but I’ve just seen this on FB. Looks very smart.😎 I asked the owner for more info but he didn’t seem to interested in looking for the info. He did say it was done in Germany.


92915867-A3DA-47AC-BF47-B10105B5EFB2.png
Got two of those, one for the RS4 and one originally for the allroad. I understand that the allroad one is a slot in for the RS6. Just that I have new DIS on both cars and have been waiting for the DIS to start playing up before changing them out. Memory is a bit dodgy but I remember them coming from Russia. The ones that I have seen fitted have looked fantastic.
colour DIS 1.jpg
colour DIS 2.jpg
C5 RS6, Milltek and Wagners: B5 RS4 450 + HP: A4 1.8 GP TQS original: 1963 UNIMOG 404:

Post Reply

Return to “RS6 / RS6 plus (C5 Typ 4B) 2002-2004”

Who is online

Users browsing this forum: srichards and 26 guests