SOS help from NZ

2.7 V6 30v biturbo - 380 bhp
Post Reply
sarainader
Neutral
Posts: 1
Joined: Sat Jan 16, 2021 12:36 pm

SOS help from NZ

Post by sarainader » Sat Jan 16, 2021 12:37 pm

Hi,

I have an RS4, Emrald Green (only one in the world). Yesterday red exclamation mark plus oil sensor and headlight warning. Dealer says new instrument cluster. I have an oled dsplay I was waiting to replace the streaky one with. Is this the issue or is it really the whole cluster that needs replacing?

Any immediate help gratefully accepted!

Thanks

kiwi_rs4
Neutral
Posts: 20
Joined: Thu May 29, 2008 8:11 pm
Location: Auckland, NZ

Re: SOS help from NZ

Post by kiwi_rs4 » Sat Jan 16, 2021 11:37 pm

You are a lucky guy having one in that colour. I have a serious soft spot for green cars (makes me an outlier I guess) but have never owned one. Got close in 2001 but I digress.

As a fellow kiwi can I suggest contacting Anything Electronic in Nelson as they may be able to repair it? It would be very useful for them to have any stored error codes from the instrument cluster. A scan tool can retrieve these or ask an independent specialist to scan it for you (dealers aren't allowed to give out the codes). In the unlikely event you are in Auckland I'd be happy to do it for free. The clusters are quite straight forward to remove (google that one). If able to repair, Anything Electronic may also be able to change the main LCD screen for you. If they won't do it try Robinson Instruments in Auckland. The screen itself won't be the cause of the warnings.

http://www.anythingelectronic.co.nz/aenz/
https://www.robinsoninstruments.co.nz

User avatar
IchBautAuto
4th Gear
Posts: 519
Joined: Thu Feb 20, 2014 11:23 pm
Location: Australia

Re: SOS help from NZ

Post by IchBautAuto » Sun Jan 17, 2021 8:22 am

Interesting, I replied to this, this morning and it's disappeared! Firstly, check fault codes. Secondly, while clusters are easy to remove they aren't that easy to find so I'd caution on jumping on that solution without being very sure it was a faulty cluster. You mentioned the DIS and replacing that is easy but that wasn't your real question if I read your initial post right.
C5 RS6, Milltek and Wagners: B5 RS4 450 + HP: A4 1.8 GP TQS original: 1963 UNIMOG 404:

Mav8
3rd Gear
Posts: 401
Joined: Sat Jul 19, 2014 8:06 pm

Re: SOS help from NZ

Post by Mav8 » Sun Jan 17, 2021 2:31 pm

Can’t help with the issue-soz
But would like to see some pics👍
Nogaro B7-Gone
MRC remap
Custom exhaust

Post Reply

Return to “RS4 (B5 Typ 8D) 1999-2001”

Who is online

Users browsing this forum: No registered users and 27 guests